Genesis GV70 Forum & GV80 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I am receiving constant and frequent alert warnings to check the system, System seems to reset itself, but repeats alerts.
System diagnostics show no issues.
Contacted Genesis CS by contact email, no response yet. [twice}

Wonder if this issue is related to the Map View timeout and related mentioned recent update?

Cleaned front camera and radar sensors. no change
 

·
Registered
Joined
·
44 Posts
I am receiving constant and frequent alert warnings to check the system, System seems to reset itself, but repeats alerts.
System diagnostics show no issues.
Contacted Genesis CS by contact email, no response yet. [twice}

Wonder if this issue is related to the Map View timeout and related mentioned recent update?

Cleaned front camera and radar sensors. no change
Do you also experience the Disappearing Map error where the 14” display changes itself to the Icons view or the Sceensaver Temperature/Time screen? I have both problems (Check Lane Assist System and Map disappearance). Dealer told me an upcoming update will fix both issues.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Yes, customer service responded and scheduled a service. Claimed this was a new problem to them??, Because I have learned that a customer already received a software update to fix this problem from Genesis. Customer service has no clue, pity Genesis
 

·
Registered
Joined
·
1 Posts
I’m having a similar issue that I posted about on Reddit. I also turned off my lane change assist feature, but the map still restarts.

Did you end up being able to resolve the issue?

Edit: I just realized you have a GV80. I have a GV70 and it looks like we have the same problem.
 
1 - 4 of 4 Posts
Top