Genesis GV70 Forum & GV80 Forum banner
21 - 40 of 41 Posts

·
Registered
Joined
·
23 Posts
Ok, so as soon as replying to you above they told me they updated the software and it's still not working. They then told me exactly what you were told that Genesis is working on an update that should be ready in September. They explained that in the other vehicles that they reinstalled the software the system then functioned properly, but not on mine. They actually had another GV80 in there now they worked on just before mine and it worked. So unfortunately I don't have an OS version to give you, we're all in the same boat right now, we have to wait a little for the fix.
By the way, my problem did not develop until 5 months after driving the car with no problem. So, it is very possible that the reuploaded car you saw repaired at the dealer service may redevelop the same problem after the owner goes home with it. My problem started intermittently and now it’s every day. That’s often the risk/cost of being an early adopter. It comes with the territory. That’s how I’m consoling myself. I’m not happy about it but it’s a fact of life. Hopefully the fix will be on time and reliable.
 

·
Registered
Joined
·
289 Posts
I had a hunch that might happen. When I had talked to my service manager he said, previously when they tried to fix the problem by reinstalling the latest current OS, it did not fix the problem permanently. So he said it was not worthwhile reinstalling the latest current OS (which my GV came with) and that we would have to wait. He did not want to promise September because he said the updates are not always released on time. I thought that was honest. Thanks much for letting me know your experience.
Let's keep in touch on this, thanks.
 

·
Registered
Joined
·
289 Posts
The more systemic the issue is with owners the more urgent it is for Genesis engineers to correct it.
 

·
Registered
Joined
·
5 Posts
The more systemic the issue is with owners the more urgent it is for Genesis engineers to correct it.
Add another GV80 to this list. 2 months of ownership and this problem has occurred. To be honest, I am pleased to see this problem was not unique to my car. I am hopeful for a software fix soon.
 

·
Registered
Joined
·
2 Posts
Has anybody had an issue with maps, were it constantly takes you to the wrong place? It gets the roads right, the location of my car right, but my final destination is usually 5 - 10 miles off. Like it forgets their address. When I enter it, it is the correct address, but it will take me to the middle of a road that is not even the road my destination is on. I end up having to use my phone with android auto and it's frustrating. I have the GV70 sport prestige with most current software.
 

·
Registered
Joined
·
289 Posts
Let's keep in touch on this, thanks.
Just a heads-up. My GPS works again and doesn't black out anymore after a few minutes. I suspect Genesis updated the software remotely as I haven't brought the car back. Is yours working now?
 

·
Registered
Joined
·
8 Posts
Just a heads-up. My GPS works again and doesn't black out anymore after a few minutes. I suspect Genesis updated the software remotely as I haven't brought the car back. Is yours working now?
The problem went away a week ago after I updated my navigation software And other software Per the description.
 

·
Registered
Joined
·
5 Posts
The problem went away a week ago after I updated my navigation software And other software Per the description.
Yes. I noticed the same thing. My navigation was working normally last week. It must have been a remote update. However, I had a regularly scheduled maintenance appointment yesterday and had them do a software update just to be safe. It is available. No problems.
 

·
Registered
Joined
·
289 Posts
Yes. I noticed the same thing. My navigation was working normally last week. It must have been a remote update. However, I had a regularly scheduled maintenance appointment yesterday and had them do a software update just to be safe. It is available. No problems.
Correct, it must have been a remote update because I didn't bring my GV80 back since I did about 6 weeks ago or so and at that time they re-downloaded the software and my gps was still blacking out. But suddenly last week it started working fine so it had to have been a remote update. The Lane Change Assist feature must be working correctly again too because the malfunction indicator isn't triggered anymore. Nice to know software updates can be done remotely.
 

·
Registered
Joined
·
289 Posts
I had a hunch that might happen. When I had talked to my service manager he said, previously when they tried to fix the problem by reinstalling the latest current OS, it did not fix the problem permanently. So he said it was not worthwhile reinstalling the latest current OS (which my GV came with) and that we would have to wait. He did not want to promise September because he said the updates are not always released on time. I thought that was honest. Thanks much for letting me know your experience.
My gps is working correctly now via an apparent remote update, no more black outs on the screen. Others in the thread mentioned the theirs are now working correctly now too. How about yours?
 

·
Registered
Joined
·
23 Posts
Yes indeed AJB, my map screen also magically appeared to fix itself just three days before my appointment to have the dealer install the newest August map and software update. I monitored the screen stability for three days before my appointment and it remained perfect. But, because I was not certain that it would be a permanent self fix, I kept my appointment with the dealer to install the August fix anyway, just to be sure I have the newest update. So far the map has stayed on. However a few times I noticed that, when programming a destination, there seemed to be a lag of “calculating“ processing when programming the destination. Early on after the dealer update, I had one incident where the screen appeared to freeze and the car was unable to calculate/process a new destination input. Similar to the spinning Beachball on a Mac desktop computer or the spinning cursor on other computers during processing/calculating, the map “Calculating” icon was just spinning in a circle with no processing conclusion. I had to turn off the engine, turn the car back on, and then the processing worked after I input the destination again. So I am not 100% certain that the dealer’s install of the operating system was 100% perfect. I am monitoring the situation to see if it will iron itself out. Hopefully it will operate smoothly from now on and that my experience was just a temporary glitch. If not, I will have to call the dealer back for a reinstall. This is just another example of where Corporate and Dealer Genesis could have better communication with owners. If they had told us (and all dealers) that they were sending out the over the air update, then I would know to expect it and not have to bring it into the dealer in the first place. Maybe the over the air update, in my case, would have been better than the dealer install. Now I really do not now. So I will just monitor, on a daily basis, and hope the dealer installed software functions and holds well. Have you noticed any lag in Destination processing where the “Calculating” notice takes a little longer?
 

·
Registered
Joined
·
289 Posts
Yes indeed AJB, my map screen also magically appeared to fix itself just three days before my appointment to have the dealer install the newest August map and software update. I monitored the screen stability for three days before my appointment and it remained perfect. But, because I was not certain that it would be a permanent self fix, I kept my appointment with the dealer to install the August fix anyway, just to be sure I have the newest update. So far the map has stayed on. However a few times I noticed that, when programming a destination, there seemed to be a lag of “calculating“ processing when programming the destination. Early on after the dealer update, I had one incident where the screen appeared to freeze and the car was unable to calculate/process a new destination input. Similar to the spinning Beachball on a Mac desktop computer or the spinning cursor on other computers during processing/calculating, the map “Calculating” icon was just spinning in a circle with no processing conclusion. I had to turn off the engine, turn the car back on, and then the processing worked after I input the destination again. So I am not 100% certain that the dealer’s install of the operating system was 100% perfect. I am monitoring the situation to see if it will iron itself out. Hopefully it will operate smoothly from now on and that my experience was just a temporary glitch. If not, I will have to call the dealer back for a reinstall. This is just another example of where Corporate and Dealer Genesis could have better communication with owners. If they had told us (and all dealers) that they were sending out the over the air update, then I would know to expect it and not have to bring it into the dealer in the first place. Maybe the over the air update, in my case, would have been better than the dealer install. Now I really do not now. So I will just monitor, on a daily basis, and hope the dealer installed software functions and holds well. Have you noticed any lag in Destination processing where the “Calculating” notice takes a little longer?
Glad to hear your problem seems to be fixed. I haven't plugged in a route in the GPS yet since the over the air software update. I only used the car once since the update as it's my wife's car and she hasn't plugged in a GPS route in either. I just noticed that there's no more GPS blackouts. I'll plug in a route sometime over the week and see how the system responds, if there's any lag time or freezes.
I totally agree that Genesis needs to step up its game and act like a premium car company. Separating their dealerships and service centers is key to their success.
 

·
Registered
Joined
·
23 Posts
Good to see your update. I drove the car several times yesterday and the map held stable. I did not have any more screen freezes after the one time day-after-installation freeze. The spinning “Calculating” notice is most clearly visible on the heads up display where the turn by turn directions show up on the windshield immediately after inputting a new destination. It is more difficult to see the very small processing icon at the bottom left of the 15” map screen itself. The processing is not a long delay, so it is even possible that I never noticed it in the past but was always there. I may just be more sensitized to the processing operation because of the glitches of the past. And if the processing is taking some seconds more, it is still acceptable as long as I do not have a complete freeze up a second time. So far so good. I’ll still be interested in seeing if you notice a longer processing time for creating the destination route than you had In the past. Thank you.
 

·
Registered
Joined
·
289 Posts
Yes indeed AJB, my map screen also magically appeared to fix itself just three days before my appointment to have the dealer install the newest August map and software update. I monitored the screen stability for three days before my appointment and it remained perfect. But, because I was not certain that it would be a permanent self fix, I kept my appointment with the dealer to install the August fix anyway, just to be sure I have the newest update. So far the map has stayed on. However a few times I noticed that, when programming a destination, there seemed to be a lag of “calculating“ processing when programming the destination. Early on after the dealer update, I had one incident where the screen appeared to freeze and the car was unable to calculate/process a new destination input. Similar to the spinning Beachball on a Mac desktop computer or the spinning cursor on other computers during processing/calculating, the map “Calculating” icon was just spinning in a circle with no processing conclusion. I had to turn off the engine, turn the car back on, and then the processing worked after I input the destination again. So I am not 100% certain that the dealer’s install of the operating system was 100% perfect. I am monitoring the situation to see if it will iron itself out. Hopefully it will operate smoothly from now on and that my experience was just a temporary glitch. If not, I will have to call the dealer back for a reinstall. This is just another example of where Corporate and Dealer Genesis could have better communication with owners. If they had told us (and all dealers) that they were sending out the over the air update, then I would know to expect it and not have to bring it into the dealer in the first place. Maybe the over the air update, in my case, would have been better than the dealer install. Now I really do not now. So I will just monitor, on a daily basis, and hope the dealer installed software functions and holds well. Have you noticed any lag in Destination processing where the “Calculating” notice takes a little longer?
I tried the Navigation over the weekend an
Good to see your update. I drove the car several times yesterday and the map held stable. I did not have any more screen freezes after the one time day-after-installation freeze. The spinning “Calculating” notice is most clearly visible on the heads up display where the turn by turn directions show up on the windshield immediately after inputting a new destination. It is more difficult to see the very small processing icon at the bottom left of the 15” map screen itself. The processing is not a long delay, so it is even possible that I never noticed it in the past but was always there. I may just be more sensitized to the processing operation because of the glitches of the past. And if the processing is taking some seconds more, it is still acceptable as long as I do not have a complete freeze up a second time. So far so good. I’ll still be interested in seeing if you notice a longer processing time for creating the destination route than you had In the past. Thank you.
I tried the Navigation over the weekend and I noticed a little more calculating time but it's barely noticeable. Everything seems back to normal, all done through a remote update.
 

·
Registered
Joined
·
23 Posts
Good to hear back from you about your positive experience. I’m also glad that you were kind enough to check the “Calculating“ time when I would see the spinning icon showing that it’s processing a Navigation Destination input. I have not had any glitches since the first freeze which I had the day after my dealer OS install (which was done several days after the automatic on air install which I was not aware had been done and appeared to correct the problematic issues). So it looks like mine is functioning exactly like yours, which you did on air. I am OK with the several seconds delay in extra processing time. As you indicate, It’s not that significant. The important thing is that the system is reliable and accurate. The driving experience is definitely more relaxing and happier when I’m not worrying about blank Map screens and freeze ups. Best of luck with your vehicle enjoyment.
 

·
Registered
Joined
·
289 Posts
Good to hear back from you about your positive experience. I’m also glad that you were kind enough to check the “Calculating“ time when I would see the spinning icon showing that it’s processing a Navigation Destination input. I have not had any glitches since the first freeze which I had the day after my dealer OS install (which was done several days after the automatic on air install which I was not aware had been done and appeared to correct the problematic issues). So it looks like mine is functioning exactly like yours, which you did on air. I am OK with the several seconds delay in extra processing time. As you indicate, It’s not that significant. The important thing is that the system is reliable and accurate. The driving experience is definitely more relaxing and happier when I’m not worrying about blank Map screens and freeze ups. Best of luck with your vehicle enjoyment.
Thank you and safe traveling with your GV80. Keep in touch...
 
21 - 40 of 41 Posts
Top