Genesis GV Forums banner
1 - 4 of 4 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi, first things first... I love my GV60, but....For a while now I've been having problems charging my GV60 (i have 2 chargers) first I had to change settings to reduced and it worked for a couple of months but recently even with reduced charging settings I keep getting charging unsuccessful message while charging. I have even set my charger to 25 AMP instead of the normal 40 AMP setting that I used without success. Any suggestions?
 

· Registered
Joined
·
30 Posts
Only suggestion I can think of is to test the charger on another vehicle to make sure the charger is the issue, not the car. Have a friend with an EV you can use for testing?
Agree. If you don't have a friend with an EVSE, try one of the stores that offers free level 2 charging (such as Whole Foods). If there isn't one of those around, and there is an EA, go there and try it. If no EA, find any unit, preferably one without a basic initial charge fee. If it doesn't work on another EVSE, then the problem is likely the car charger; if it does work on another EVSE, then your problem is probably the EVSE.
 

· Registered
Joined
·
2 Posts
Hi, first things first... I love my GV60, but....For a while now I've been having problems charging my GV60 (i have 2 chargers) first I had to change settings to reduced and it worked for a couple of months but recently even with reduced charging settings I keep getting charging unsuccessful message while charging. I have even set my charger to 25 AMP instead of the normal 40 AMP setting that I used without success. Any suggestions?
Why in the world would you buy EV in the first place……
 
1 - 4 of 4 Posts
Top