Genesis GV70 Forum & GV80 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
621 Posts
Welcome to the forum @Jimmymoc
You could have a bad battery or something draining power more than it should.
Did you speak to your dealer about getting it looked at?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Welcome to the forum @Jimmymoc
You could have a bad battery or something draining power more than it should.
Did you speak to your dealer about getting it looked at?
No
Welcome to the forum @Jimmymoc
You could have a bad battery or something draining power more than it should.
Did you speak to your dealer about getting it looked at?
Unfortunately yes. Car had to be towed in and brake lights would not shut down and since it was 24 hours before they looked at it...deader than a doorknob...so they charged it up and said ok. Told us we need to drive it more??
I don't want to take this as an option.
 

·
Registered
Joined
·
61 Posts
Has anyone had battery issues when car not used for a couple days?
There were comments on the GV80 board that batteries were being drained due to keeping the smart key too close to the vehicle and they were continuosly "talking" to each other.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
That sounds like a valid explanation however my keys are quite a distance from the car..I'm upstairs and car is in underground garage. But thanks for that insight.
 

·
Registered
Joined
·
14 Posts
No

Unfortunately yes. Car had to be towed in and brake lights would not shut down and since it was 24 hours before they looked at it...deader than a doorknob...so they charged it up and said ok. Told us we need to drive it more??
I don't want to take this as an option.
I agree, driving it more wouldn't be an option. I've not ever had a car battery drain when not being driven for a few days. I'd push to have them do a better diagnostic on it.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
I agree, driving it more wouldn't be an option. I've not ever had a car battery drain when not being driven for a few days. I'd push to have them do a better diagnostic on it.
Well we did push for a different answer but two techs came up with same answer. Requested a new battery and said they could not do because diagnostics did not show a battery fail after charged up. I guess they want me to get caught in a roadside assistance situation again. I would not be happy to go thru that again. What can i do?
 
1 - 7 of 7 Posts
Top