Genesis GV70 Forum & GV80 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Just a few days ago, I was driving my GV80 Prestige, an error came up on the screen, low air pressure in the left rear tire.
It read 12psi, then a few seconds later it changed to 39psi. (In Canada the vehicles with 22" tires recommend 41psi)
The problem is, the error stays on the screen. I checked my tire pressure when I got home and it was 39psi.
Now 3-4 days later the error is still on the screen.
Does anyone know how to reset the TPMS? Or maybe it is faulty and needs to be serviced at the Genesis dealer.
 

·
Registered
Joined
·
2 Posts
Just a few days ago, I was driving my GV80 Prestige, an error came up on the screen, low air pressure in the left rear tire.
It read 12psi, then a few seconds later it changed to 39psi. (In Canada the vehicles with 22" tires recommend 41psi)
The problem is, the error stays on the screen. I checked my tire pressure when I got home and it was 39psi.
Now 3-4 days later the error is still on the screen.
Does anyone know how to reset the TPMS? Or maybe it is faulty and needs to be serviced at the Genesis dealer.
The other o was driving and a error came up to say my back right tire was at 22psi. I pulled over to a gas station to add air then it said it back to normal. I havent gotten the error recently but going to monitor it
 

·
Registered
Joined
·
1 Posts
Just a few days ago, I was driving my GV80 Prestige, an error came up on the screen, low air pressure in the left rear tire.
It read 12psi, then a few seconds later it changed to 39psi. (In Canada the vehicles with 22" tires recommend 41psi)
The problem is, the error stays on the screen. I checked my tire pressure when I got home and it was 39psi.
Now 3-4 days later the error is still on the screen.
Does anyone know how to reset the TPMS? Or maybe it is faulty and needs to be serviced at the Genesis dealer.
I had a similar experience with a low tire pressure warning for my left rear tire (18lbs). It lasted about 4 blocks (before I could turn into a parking lot) then went away and then displayed the correct 45lbs for the tire. It only happened this one time (I have had the GV80 for 2 months). I have the incident on a short list of issues to address with the dealer when it goes in for service. Good luck!
 
1 - 4 of 4 Posts
Top