Genesis GV70 Forum & GV80 Forum banner
21 - 40 of 58 Posts

·
Registered
Joined
·
18 Posts
My first tank of gas I got 353 miles the computer said I average 12.2 miles per gallon almost all City I cannot believe that's accurate. Put 18 gallons in it when I filled it up so that's closer to it 19 miles per gallon
I’m getting close to 19 per gallon, but I don’t do much in traffic driving.
 

·
Registered
Joined
·
18 Posts
My main issue is the blind spot alert is signaled (in the side view mirror and dash) when a car is a full car length behind me...that’s too far. And because the alert is triggered , the car will buzz and warn as though I’m going hit something even though I’m safely changing lanes, which is distracting and a false alarm. I’ve driven many cars with blind spot alert , and never had one trigger unless a car was really in your blind spot. As far as I can tell, this is not configurable.
 

·
Registered
Joined
·
624 Posts
Discussion Starter · #23 ·
My main issue is the blind spot alert is signaled (in the side view mirror and dash) when a car is a full car length behind me...that’s too far. And because the alert is triggered , the car will buzz and warn as though I’m going hit something even though I’m safely changing lanes, which is distracting and a false alarm. I’ve driven many cars with blind spot alert , and never had one trigger unless a car was really in your blind spot. As far as I can tell, this is not configurable.
If its not configurable, then I'm sure it can eventually. If Adaptive Cruise Control has that option (which it does on many new cars) then I can't imagine it being that hard to implement here.
Try reaching out to Genesis Corporate and see what they say if you haven't already. Keep us posted if you do.
 

·
Registered
Joined
·
25 Posts
Anyone have radio cutting out? While driving, I often experience 2 of the four speakers(always fronts) cutting out, while the back ones are still operating...it lasts for a good 10 seconds and then comes back on....If I sit in my driveway it doesn't happen, so it must have something to do with the GV moving...If it were the satelite, I'd think the car would go completely quiet.
2nd day dring it!!
Did you ever find the problem? Mine does too. Even playing a podcast through my phone to the radio.
Dennis Corso
 

·
Registered
Joined
·
25 Posts
11.5mpg (100 miles and mostly city so far, the efficiency will improve slightly after more mileage but won't much) vs 20mpg per EPA
My previous car (Audi Q5) was 23.8mpg.
After about 1500 miles or so, I am getting 21-22 mpg on the road. Varies slightly depending on the terrain
 

·
Registered
Joined
·
40 Posts
Did you ever find the problem? Mine does too. Even playing a podcast through my phone to the radio.
Dennis Corso
No not yet. It seems like it might be a slightly loose connection. If it was a slow blow fuse ( which is the closest example I have experienced) it would have blown by now. And a loose wire would have also gotten looser. Ive considered that its a sirius problem but. I don't think its is. I haven't contacted the dealer he's 3 hours away so I was hoping that someone had dealt with it. Its not all the time nut its happening still. Only 2 months old but it started the 2nd day I got it. Its annoying as **** but I can kinda live with it for now. But when I go in for 1st service it will be addressed if it stays intermittant
 

·
Registered
Joined
·
19 Posts
After about 1500 miles or so, I am getting 21-22 mpg on the road. Varies slightly depending on the terrain
I just finished a 1400 mile road trip and saw a max of 24.5 MPG per the car’s computer on VERY steady highway driving. The whole trip averaged just over 21 with a fair amount of city bits mixed in. Considering the vehicles all around performance I’m happy.
 

·
Registered
Joined
·
7 Posts
My main issue is the blind spot alert is signaled (in the side view mirror and dash) when a car is a full car length behind me...that’s too far. And because the alert is triggered , the car will buzz and warn as though I’m going hit something even though I’m safely changing lanes, which is distracting and a false alarm. I’ve driven many cars with blind spot alert , and never had one trigger unless a car was really in your blind spot. As far as I can tell, this is not configurable.
Agree with you. Observing the same thing. If car comes up fast and continues past you then it works and makes sense. If car behind you lags warning less effective
 

·
Registered
Joined
·
2 Posts
Anyone have issues with Apple CarPlay randomly disconnecting and then reconnecting? It might be my off brand lightning cable but I wanted to see if there was someone else with the same problem. Not seeing it in this thread is a good sign.
 

·
Registered
Joined
·
9 Posts
Any experiencing issues with the Wireless Phone Charging System? I have a Samsung S21 Plus that will not charge in the GV 80 Wireless Charger. Would be interested to hear from owners of S21 and GV 80 having the same issue.
 

·
Registered
Joined
·
1 Posts
Anyone have problem or heard of problems with "engine control computer"? Purchased a 2021 GV-80 3.5T Prestige - Gold Coast Silver. At 5,155 miles had to have towed to Genesis dealer. Currently in dealer shop, 16 days and counting. Local Techs and Genesis headquarters stated this "engine control computer complete failure" is a first known failure identified with this control system. However, they're still not sure this is the real issue. Genesis technical has contacted me for further information on symptoms - rough idle, high level of engine vibration, no power, max speed approx. 15 mph. Parts on backorder, soonest parts delivery is an additional 30 days, maybe.

Loved the GV-80, but now have long-term trust/reliability concerns. Anyone else?
 

·
Registered
Joined
·
3 Posts
I have a rattle noise coming from the rear passenger side door. Trying to pinpoint before taking it in to the dealer.
I just developed a rattle, too, after 2500 miles. It also appears to be coming from the passenger side door. Were you able to identify it, and get it fixed?
 

·
Registered
Joined
·
6 Posts
Check your seat belt. mine rattled with the seats in the folded position ( metal fastener on .seat belt against the side of the door post)
 

·
Registered
Joined
·
5 Posts
Anyone have radio cutting out? While driving, I often experience 2 of the four speakers(always fronts) cutting out, while the back ones are still operating...it lasts for a good 10 seconds and then comes back on....If I sit in my driveway it doesn't happen, so it must have something to do with the GV moving...If it were the satelite, I'd think the car would go completely quiet.
2nd day dring it!!
I am having the same issue. I have only had my car for 5 days and this started today.
 

·
Registered
Joined
·
5 Posts
I am having the same issue. I have only had my car for 5 days and this started today.
I found out how to fix this issue....Under the Sound settings, there are many things checked for the volume to go down. ie: volume down when you put on the turn signal, volume down when you reverse, etc. Go to this section and turn them off. It worked for me.
 

·
Registered
Joined
·
5 Posts
I am having the same issue. I have only had my car for 5 days and this started today.
I found out how to fix this issue....Under the Sound settings, there are many things checked for the volume to go down. ie: volume down when you put on the turn signal, volume down when you reverse, etc. Go to this section and turn them off. It worked for me.
 

·
Registered
Joined
·
5 Posts
No not yet. It seems like it might be a slightly loose connection. If it was a slow blow fuse ( which is the closest example I have experienced) it would have blown by now. And a loose wire would have also gotten looser. Ive considered that its a sirius problem but. I don't think its is. I haven't contacted the dealer he's 3 hours away so I was hoping that someone had dealt with it. Its not all the time nut its happening still. Only 2 months old but it started the 2nd day I got it. Its annoying as **** but I can kinda live with it for now. But when I go in for 1st service it will be addressed if it stays intermittant
I found out how to fix this issue....Under the Sound settings, there are many things checked for the volume to go down. ie: volume down when you put on the turn signal, volume down when you reverse, etc. Go to this section and turn them off. It worked for me.
 

·
Registered
Joined
·
1 Posts
Towing a bike rack and cannot backup safely. The GV80 stops abruptly no matter how slow I am going and then surges when I try to get out of the forced stopped, no matter how gently I use the gas pedal! It is a dangerous design flaw…
 
21 - 40 of 58 Posts
Top