Genesis GV Forums banner
81 - 100 of 112 Posts

· Registered
Joined
·
231 Posts
My GV80 2.5 T has many software glitches…
Navigation system…always unavailable
Apple CarPlay…won’t connect via cable
Lane change assist…fault message
Font & side sensor falsely detecting when nothing is there
All cameras come on after backing out of parking space and continue to stay on for awhile while driving
Only 4000 miles and wondering if more issues to come
This is my 2nd genesis I’ve owned…Genesis is not a reputable luxury brand…service is substandard and think this brand will struggle to convince buyers to buy Genesis brand….just an over priced Hyundai
Navigation system…always unavailable
This may be a GPS issue, I was getting route unavailable but it's working again so perhaps the GPS was unable to link to the car at the time.

Apple CarPlay…won’t connect via cable
Is it plugged into the leftmost plug? it's the only one that connects the phone to the infotainment screen.
Is it an Apple cable? Maybe try that.

Lane change assist…fault message
Are you putting the blinker to position B and holding it there until the side marker turns green on the dash? If you put the blinker all the way on it doesn't work. If you turn the steering wheel at all it stops it from working.

Font & side sensor falsely detecting when nothing is there
Look to see if there is a Ford F150 near you. They set the cameras off notoriously.

All cameras come on after backing out of parking space and continue to stay on for awhile while driving
Cameras are set to work until you get to 9 mph going forward before they turn off.
 

· Registered
Joined
·
96 Posts
Lane change assist…fault message
Are you putting the blinker to position B and holding it there until the side marker turns green on the dash? If you put the blinker all the way on it doesn't work. If you turn the steering wheel at all it stops it from working.
I find this very hard to use as I still look over my shoulder to make sure it's clear. When I do that I must turn the wheel just enough to register as it always cancels due to steering imput.(direction does not change)
Sorry but I can't change lanes and just trust technology that I'm not going to hit something.
 

· Registered
2021 GV80 Prestige
Joined
·
69 Posts
My GV80 2.5 T has many software glitches…
Navigation system…always unavailable
Apple CarPlay…won’t connect via cable
Lane change assist…fault message
Font & side sensor falsely detecting when nothing is there
All cameras come on after backing out of parking space and continue to stay on for awhile while driving
Only 4000 miles and wondering if more issues to come
This is my 2nd genesis I’ve owned…Genesis is not a reputable luxury brand…service is substandard and think this brand will struggle to convince buyers to buy Genesis brand….just an over priced Hyundai
I can speak to a few of these, I have a 2021 GV80 3.5 Prestige (5100 miles):
Carplay - while i use AA, i had the same issue, until I went with a real hig quality data cable that was on 1' long
Sensor issue - Alot of people have reported this, incl me, and it seems to have to do with cross talk with other newer cars (I have always found it to be a new Ford) that is nearby
Cameras: yes, they come on and stay on until you hit 10mph (and the sound volume is lowered as well)
 

· Registered
Joined
·
16 Posts
Anyone have issues with Apple CarPlay randomly disconnecting and then reconnecting? It might be my off brand lightning cable but I wanted to see if there was someone else with the same problem. Not seeing it in this thread is a good sign.
Yes, I have been using original apple cables and it keeps disconnecting the apple car play. I have to unplug it and replug and it comes back. Not sure if it is my cable, or phone, or the car?
 

· Registered
Joined
·
6 Posts
After about 10K miles I’m getting a front end rattle when driving slow over uneven pavement. (Railroad tracks, pulling in driveway, rough road). Sounds like a cheaply made vehicle after a few years. Not what I paid for.

Was perfectly smooth before that.
Dealership has replaced front end components TWICE, and have been unable to fix the issue. They have said it’s a “known issue” with the GV80.

Not sure what my recourse can be if they can’t fix it?
 

· Registered
Joined
·
81 Posts
After about 10K miles I’m getting a front end rattle when driving slow over uneven pavement. (Railroad tracks, pulling in driveway, rough road). Sounds like a cheaply made vehicle after a few years. Not what I paid for.

Was perfectly smooth before that.
Dealership has replaced front end components TWICE, and have been unable to fix the issue. They have said it’s a “known issue” with the GV80.

Not sure what my recourse can be if they can’t fix it?
Are you sure it's in the front end? Sometimes in a car things can echo or seem to be coming from one place when it's actually another. Check your seatbelts, especially behind the driver's seat passenger side. They both have a seatbelt holder to keep the metal part from rattling against the the side panels.
 

· Registered
Joined
·
6 Posts
Are you sure it's in the front end? Sometimes in a car things can echo or seem to be coming from one place when it's actually another. Check your seatbelts, especially behind the driver's seat passenger side. They both have a seatbelt holder to keep the metal part from rattling against the the side panels.
When I ever get my GV80 back (driving a G80 loaner), I'll certainly check all around.

Based on the road conditions and speed when it happens, I certainly tend to lean towards a suspension issue. Everyone at the dealership thought the same when they drove it.
 

· Registered
Joined
·
81 Posts
When I ever get my GV80 back (driving a G80 loaner), I'll certainly check all around.

Based on the road conditions and speed when it happens, I certainly tend to lean towards a suspension issue. Everyone at the dealership thought the same when they drove it.
Keep me updated. I'm curious about this. Especially if the techs are replacing front end parts and its not fixing it. Kind of weird that they would be replacing stuff without being sure it's the cause. But I guess they went with a trial and error troubleshooting since they weren't sure. Check the tires too. Had a co-worker who had a bolt stuck inside his tire rattling around when he get to high speeds. It wasn't a GV80 though. Just some older car some years back. You might have something in one of your front tires. Those little balancing weights they put on the tires could have gotten in your front end or your front tire. I'm just guessing though.
 

· Registered
Joined
·
6 Posts
I don’t know enough about cars to relate to what they told me…. But they thought they had it narrowed to the front right strut because they had disconnected the swing arm (?) and the noise went away. Will advise
 

· Registered
Joined
·
1 Posts
My GV80 2021 is a great car - I love it -- except lately I have been recording a noise that sounds like it is coming from the front dash area. Maybe the steering column or I don't know where. I have it at the dealer right now. This is the second time I have taken it in for this same issue. I have recorded the sound. It happens when the car is not on, when it is on, when I am driving, when I am not driving, when the air is on and when the ac is off - I cannot figure out any consistent reason for this noise. The dealer is taking the car home so he can hear the noise - even though I have him the recording.

Anyone else have this problem
 

· Registered
Joined
·
6 Posts
Keep me updated. I'm curious about this. Especially if the techs are replacing front end parts and its not fixing it. Kind of weird that they would be replacing stuff without being sure it's the cause. But I guess they went with a trial and error troubleshooting since they weren't sure. Check the tires too. Had a co-worker who had a bolt stuck inside his tire rattling around when he get to high speeds. It wasn't a GV80 though. Just some older car some years back. You might have something in one of your front tires. Those little balancing weights they put on the tires could have gotten in your front end or your front tire. I'm just guessing though.
Still don’t have my GV80 back. Been what?…. Over 2 months at least.
Have Genesis Consumer Affairs involved. Am told they have the whole front end apart. Genesis tech line/engineers involved.
I asked them about a lemon law replacement….. awaiting a definitive answer there.
On a side note, the G80 loaner makes a noise every time I hit the gas pedal. I think I saw someone mention them were told it was a fuel control module issue. My loaner has that issue. 🤷🏼‍♂️
First foray into the Genesis brand. Not really impressed so far.
 

· Registered
Joined
·
3 Posts
Update on our GV-80 "engine control Computer" issue:
After breaking down in late April 2021 with 5,155 miles, several repair attempts, in-person visits from Genesis Engineering (both U.S. and South Korean), it was decided that they did not know what was causing the issue with our 2021 3.5 Prestige GV-80. They voluntarily placed the vehicle in the State Lemon Law program, and consented to replace it at no cost to us. We were due delivery in June of a replacement 2021 3.5 Prestige GV-80. Due to the parts, COVID and delivery chain issues, we are now scheduled to get our replacement vehicle in March 2022. It will be a 2022. With the exception of the delivery delays, Hyundai / Genesis has been very good to work with, including providing us a new GV-80 base model to drive for the past 8 months.
WE received our 2022 GV-80 3.5T as promised. Now with 12,000+ miles, GREAT VEHICLE!! The old Gold Coast Siver one that was replaced by the state lemon law still sits on the dealer's lot. Hyundai/Genesis corporate owns it but has seemingly abandoned it. The dealership jokes about it being the longest resident ever on their lot!
 

· Registered
Joined
·
6 Posts
Keep me updated. I'm curious about this. Especially if the techs are replacing front end parts and its not fixing it. Kind of weird that they would be replacing stuff without being sure it's the cause. But I guess they went with a trial and error troubleshooting since they weren't sure. Check the tires too. Had a co-worker who had a bolt stuck inside his tire rattling around when he get to high speeds. It wasn't a GV80 though. Just some older car some years back. You might have something in one of your front tires. Those little balancing weights they put on the tires could have gotten in your front end or your front tire. I'm just guessing though.
They’ve had my GV80 for over 4 months. I get updates from Genesis consumer affairs, but minimal info other than they’re going to try and replace this or that.
Have put almost 3000 miles on my loaner.
 

· Registered
Joined
·
10 Posts
Anyone have radio cutting out? While driving, I often experience 2 of the four speakers(always fronts) cutting out, while the back ones are still operating...it lasts for a good 10 seconds and then comes back on....If I sit in my driveway it doesn't happen, so it must have something to do with the GV moving...If it were the satelite, I'd think the car would go completely quiet.
2nd day dring it!!
I have same issue with my 2023 GV80- can’t figure it out.
 

· Registered
Joined
·
10 Posts
Have you tried without a case? My S21 charges fine, but I have other issues with it. Had to clear the Bluetooth cache on the phone in order to get it to download my contacts. The other issue I have been having is with the digital key not working.
I’m not an Android user but have same issue with my iPhone which has Apple case on it. Have to take phone out of case for wireless charging to work. Did not have this issue with my Mercedes GLE 450-annoying to say the least.
 

· Registered
Joined
·
6 Posts
Keep me updated. I'm curious about this. Especially if the techs are replacing front end parts and its not fixing it. Kind of weird that they would be replacing stuff without being sure it's the cause. But I guess they went with a trial and error troubleshooting since they weren't sure. Check the tires too. Had a co-worker who had a bolt stuck inside his tire rattling around when he get to high speeds. It wasn't a GV80 though. Just some older car some years back. You might have something in one of your front tires. Those little balancing weights they put on the tires could have gotten in your front end or your front tire. I'm just guessing though.
Final update on this.

Genesis field engineer determined that both the upper and lower control arms on the front passenger side needed replaced. That fixed the rattle!

The dealer had my vehicle for 6 months.

Hyundai Motors of America has decided to offer to repurchase my GV80. I’m going to have them do so. Submitted everything and am awaiting their final $ determination.
 

· Registered
Joined
·
10 Posts
Final update on this.

Genesis field engineer determined that both the upper and lower control arms on the front passenger side needed replaced. That fixed the rattle!

The dealer had my vehicle for 6 months.

Hyundai Motors of America has decided to offer to repurchase my GV80. I’m going to have them do so. Submitted everything and am awaiting their final $ determination.
think that’s the best move. As someone wrote on an earlier post on this thread.. Genesis brand is seemingly just an overpriced Hyundai-too many quality issues for my taste. Had I known prior would not have purchased this vehicle. Main reason I did was other luxury brands at least in my neck of the woods were tacking on a surcharge to MSRP and I was able get the GV80 at MSRP from local dealer. It’s a beautiful SUV but too many quality/production issues for my taste. If I could I would return it.
 

· Registered
Joined
·
75 Posts
I have same issue with my 2023 GV80- can’t figure it out.
When I first got my car I had this issue. I think what it was is that the front speakers would cut out to give me some info like driving directions. But The sound for the info was turned down so all that happened was the speakers from the radio would cut out. Might not be your issue, but it was what fixed if for me.
 
81 - 100 of 112 Posts
Top